ユウの小屋

PCの更新内容やSLPでの活動、開発したもの等をupしていきます

Rubyを2.1.0にアップデート

Rubyの勉強を始めたものの、「x = 1/3r」が弾かれて唖然…

 

原因は、cygwinに入れてたRubyのバージョンが1.9.0と古かったことでした。

Rational型を"r"サフィックスをつけて作れるのは、2.1.0以降のようで。

 

というわけで、2.1.0にアップデートしました。